Comau

Supporto

Lorem ipsum dolor sit amet, consectetur adipisci elit, sed eiusmod tempor incidunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur.


Lorem ipsum dolor sit amet, consectetur adipisci elit, sed eiusmod tempor incidunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrum exercitationem ullam corporis suscipit laboriosam, nisi ut aliquid ex ea commodi consequatur.

e.DO People Learn Robotics Forums Software Prototype of MoveIt package to control real eDO robots

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #8152
    Yoan Mollard
    Participant

    Hello the community,

    Here’s a working version of ROS MoveIt for a real eDO robot: https://github.com/ymollard/eDO_moveit
    It works with the addition of a control node: https://github.com/ymollard/eDO_control

    Take is as a prototype, you might want to tweak it! It currently only works with the electric gripper mounted, but cannot et actuate it.
    Also, joint limits in speed and acceleration need to be tweaked a bit because some security system seems to activate brakes when joint exceed their limits.

    This is derived from Andrej Pangercic’s retroengineering work and opensource code from Rethink Robotics.

    #8174
    Pietro Castelli
    Participant

    Hi Yoan,
    I’m trying to run your Moveit package for Edo, unfortunatly i’m having some troubles, apparently the package isn’t able to locate the urdf of the robot, I ve followed your instruction, the packages i’m using are edo_control and edo_moveit from you and edo_description and edo_core_msgs from comau.

    The error i have is this:
    “No such file or directory: /home/pietro/edo_moveit_real_cat_ws/src/eDO_description/urdf/edo.urdf.xacro
    RLException: while processing /home/pietro/edo_moveit_real_cat_ws/src/eDO_moveit/launch/planning_context.launch:
    Invalid <param> tag: Cannot load command parameter [robot_description]: command [xacro ‘/home/pietro/edo_moveit_real_cat_ws/src/eDO_description/urdf/edo.urdf.xacro’] returned with code [2].

    Param xml is <param command=”xacro ‘$(find edo_description)/urdf/edo.urdf.xacro'” if=”$(arg load_robot_description)” name=”$(arg robot_description)”/>
    The traceback for the exception was written to the log file”

    My Catkin directory for pkgs in src look like this:
    edo_moveit_real_cat_ws/src/eDO_moveit
    edo_moveit_real_cat_ws/src/eDO_description
    edo_moveit_real_cat_ws/src/eDO_control
    edo_moveit_real_cat_ws/src/edo_core_msgs

    Inside edo_moveit_real_cat_ws/src/eDO_description i have :
    config
    launch
    meshes
    robots
    ..

    Inside robots there is edo_sim.urdf which i renamed edo.urdf .
    I tried to rename edo_sim.urdf to edo_sim.urdf.xacro and move this file in a new folder called urdf , doing that rviz starts, it gives no more the previous error , but it gives this error:

    [ERROR] [1557241903.352557769]: Joint ‘edo_joint_1’ not found in model ‘edo_sim’
    [ERROR] [1557241903.352650569]: Joint ‘edo_joint_2’ not found in model ‘edo_sim’
    [ERROR] [1557241903.352719588]: Joint ‘edo_joint_3’ not found in model ‘edo_sim’
    [ERROR] [1557241903.352787932]: Joint ‘edo_joint_4’ not found in model ‘edo_sim’
    [ERROR] [1557241903.352876085]: Joint ‘edo_joint_5’ not found in model ‘edo_sim’
    [ERROR] [1557241903.352945698]: Joint ‘edo_joint_6’ not found in model ‘edo_sim’

    Do you know what am i doing wrong? Any help will be appreciated, thanks a lot

    #8175
    Yoan Mollard
    Participant

    Hi Pietro,

    I forgot to mention that I’m using the eDo_description fixed by Stefan Profanter:
    Replace yours by this one, I’ll update the README with this info.

    #8176
    Pietro Castelli
    Participant

    Hi Yoan,
    I tried also to run your packages but with the alternative edo_description uploaded by Pro, avaible at this git (https://github.com/Pro/eDO_description). When loading this package i need first to :
    export LC_NUMERIC = en_US.UTF-8 (otherwise the robot is collapsed)
    Using this package doesn’t give me problems loading urdf files but gives other error, which are:
    [ INFO] [1557243764.029822499]: rviz version 1.13.3
    [ INFO] [1557243764.029913314]: compiled against Qt version 5.9.5
    [ INFO] [1557243764.029956797]: compiled against OGRE version 1.9.0 (Ghadamon)
    [INFO] [1557243765.280478]: Initializing joint trajectory action server…
    [INFO] [1557243765.404646]: Starting eDo joint state publisher for real robot…
    [ INFO] [1557243765.506692667]: Loading robot model ‘edo’…
    [ INFO] [1557243765.524991439]: No root/virtual joint specified in SRDF. Assuming fixed joint
    [ INFO] [1557243765.716268652]: Stereo is NOT SUPPORTED
    [ INFO] [1557243765.740012578]: OpenGl version: 2.1 (GLSL 1.2).
    [ WARN] [1557243766.010250745]: Kinematics solver doesn’t support #attempts anymore, but only a timeout.
    Please remove the parameter ‘/robot_description_kinematics/edo/kinematics_solver_attempts’ from your configuration.
    [ INFO] [1557243767.407622733]: Publishing maintained planning scene on ‘monitored_planning_scene’
    [INFO] [1557243767.447042]: Current machine state: CALIBRATED (2), opcode 0
    [ INFO] [1557243767.566920889]: MoveGroup debug mode is ON
    Starting planning scene monitors…
    [ INFO] [1557243767.567003193]: Starting planning scene monitor
    [ INFO] [1557243768.933446031]: Listening to ‘/planning_scene’
    [ INFO] [1557243768.933515964]: Starting world geometry update monitor for collision objects, attached objects, octomap updates.
    [INFO] [1557243768.979655]: Waiting for the service that disables the robot’s internal algorithm manager…
    [ INFO] [1557243769.035090279]: Listening to ‘/collision_object’ using message notifier with target frame ‘world ‘
    [WARN] [1557243769.059840]: Cannot disable internal robot’s algorithm manager, perhaps it is already disabled
    [ INFO] [1557243769.117449336]: Listening to ‘/planning_scene_world’ for planning scene world geometry
    [ INFO] [1557243769.348074805]: Listening to ‘/attached_collision_object’ for attached collision objects
    Planning scene monitors started.
    [ INFO] [1557243769.395742114]: Initializing OMPL interface using ROS parameters
    [INFO] [1557243769.753010]: Running JTAS. Ctrl-c to quit
    [ INFO] [1557243770.170502534]: Using planning interface ‘OMPL’
    [ INFO] [1557243770.179224836]: Param ‘default_workspace_bounds’ was not set. Using default value: 10
    [ INFO] [1557243770.185490169]: Param ‘start_state_max_bounds_error’ was set to 0.1
    [ INFO] [1557243770.191977686]: Param ‘start_state_max_dt’ was not set. Using default value: 0.5
    [ INFO] [1557243770.201909264]: Param ‘start_state_max_dt’ was not set. Using default value: 0.5
    [ INFO] [1557243770.208368963]: Param ‘jiggle_fraction’ was set to 0.05
    [ INFO] [1557243770.216057759]: Param ‘max_sampling_attempts’ was not set. Using default value: 100
    [ INFO] [1557243770.216377989]: Using planning request adapter ‘Add Time Parameterization’
    [ INFO] [1557243770.220484777]: Using planning request adapter ‘Fix Workspace Bounds’
    [ INFO] [1557243770.220561436]: Using planning request adapter ‘Fix Start State Bounds’
    [ INFO] [1557243770.220628050]: Using planning request adapter ‘Fix Start State In Collision’
    [ INFO] [1557243770.220693460]: Using planning request adapter ‘Fix Start State Path Constraints’
    [ INFO] [1557243772.621932980]: Loading robot model ‘edo’…
    [ INFO] [1557243772.622066493]: No root/virtual joint specified in SRDF. Assuming fixed joint
    [ WARN] [1557243773.068729405]: Kinematics solver doesn’t support #attempts anymore, but only a timeout.
    Please remove the parameter ‘/rviz_CAT_VM_16888_4682352742677865451/edo/kinematics_solver_attempts’ from your configuration.
    [ INFO] [1557243773.839422775]: Starting planning scene monitor
    [ INFO] [1557243773.910086802]: Listening to ‘/move_group/monitored_planning_scene’
    [ INFO] [1557243773.923285872]: waitForService: Service [/get_planning_scene] has not been advertised, waiting…
    [ WARN] [1557243776.821309435]: Waiting for /follow_joint_trajectory to come up
    [ INFO] [1557243778.947699693]: Failed to call service get_planning_scene, have you launched move_group? at /tmp/binarydeb/ros-melodic-moveit-ros-planning-1.0.1/planning_scene_monitor/src/planning_scene_monitor.cpp:495
    [ INFO] [1557243781.970438540]: Constructing new MoveGroup connection for group ‘edo’ in namespace ”
    [ WARN] [1557243782.821527011]: Waiting for /follow_joint_trajectory to come up
    [ERROR] [1557243788.822686901]: Action client not connected: /follow_joint_trajectory
    [ INFO] [1557243788.932296277]: Returned 0 controllers in list
    [ INFO] [1557243790.617133075]: Trajectory execution is managing controllers
    Loading ‘move_group/ApplyPlanningSceneService’…
    Loading ‘move_group/ClearOctomapService’…
    Loading ‘move_group/MoveGroupCartesianPathService’…
    Loading ‘move_group/MoveGroupExecuteTrajectoryAction’…
    Loading ‘move_group/MoveGroupGetPlanningSceneService’…
    Loading ‘move_group/MoveGroupKinematicsService’…
    Loading ‘move_group/MoveGroupMoveAction’…
    Loading ‘move_group/MoveGroupPickPlaceAction’…
    Loading ‘move_group/MoveGroupPlanService’…
    Loading ‘move_group/MoveGroupQueryPlannersService’…
    Loading ‘move_group/MoveGroupStateValidationService’…
    [ INFO] [1557243793.453148756]:

    ********************************************************
    * MoveGroup using:
    * – ApplyPlanningSceneService
    * – ClearOctomapService
    * – CartesianPathService
    * – ExecuteTrajectoryAction
    * – GetPlanningSceneService
    * – KinematicsService
    * – MoveAction
    * – PickPlaceAction
    * – MotionPlanService
    * – QueryPlannersService
    * – StateValidationService
    ********************************************************

    [ INFO] [1557243793.453289269]: MoveGroup context using planning plugin ompl_interface/OMPLPlanner
    [ INFO] [1557243793.453367161]: MoveGroup context initialization complete

    You can start planning now!

    [ERROR] [1557243812.161471349]: Unable to connect to move_group action server ‘move_group’ within allotted time (30s)
    [ INFO] [1557243812.162396291]: Constructing new MoveGroup connection for group ‘edo’ in namespace ”
    [ERROR] [1557243842.337267106]: Unable to connect to move_group action server ‘move_group’ within allotted time (30s)
    [ INFO] [1557243842.338527011]: Constructing new MoveGroup connection for group ‘edo’ in namespace ”

    #8177
    Yoan Mollard
    Participant

    Would you mind adding a rospy.loginfo() before that start() here, to check that the action server is actually requested to start?

    #8178
    Pietro Castelli
    Participant

    Hi Yoan,
    I tried to add rospy.loginfo(‘code line reached, next is server start’) to my code and the result is this:
    started roslaunch server http://CAT-VM:40625/

    SUMMARY
    ========

    PARAMETERS
    * /move_group/allow_trajectory_execution: True
    * /move_group/capabilities: move_group/MoveGr…
    * /move_group/controller_list: [{‘default’: True…
    * /move_group/edo/longest_valid_segment_fraction: 0.005
    * /move_group/edo/planner_configs: [‘SBLkConfigDefau…
    * /move_group/edo/projection_evaluator: joints(edo_joint_…
    * /move_group/eef_group/planner_configs: [‘SBLkConfigDefau…
    * /move_group/jiggle_fraction: 0.05
    * /move_group/max_range: 5.0
    * /move_group/max_safe_path_cost: 1
    * /move_group/moveit_controller_manager: moveit_simple_con…
    * /move_group/moveit_manage_controllers: True
    * /move_group/octomap_resolution: 0.025
    * /move_group/planner_configs/BFMTkConfigDefault/balanced: 0
    * /move_group/planner_configs/BFMTkConfigDefault/cache_cc: 1
    * /move_group/planner_configs/BFMTkConfigDefault/extended_fmt: 1
    * /move_group/planner_configs/BFMTkConfigDefault/heuristics: 1
    * /move_group/planner_configs/BFMTkConfigDefault/nearest_k: 1
    * /move_group/planner_configs/BFMTkConfigDefault/num_samples: 1000
    * /move_group/planner_configs/BFMTkConfigDefault/optimality: 1
    * /move_group/planner_configs/BFMTkConfigDefault/radius_multiplier: 1.0
    * /move_group/planner_configs/BFMTkConfigDefault/type: geometric::BFMT
    * /move_group/planner_configs/BKPIECEkConfigDefault/border_fraction: 0.9
    * /move_group/planner_configs/BKPIECEkConfigDefault/failed_expansion_score_factor: 0.5
    * /move_group/planner_configs/BKPIECEkConfigDefault/min_valid_path_fraction: 0.5
    * /move_group/planner_configs/BKPIECEkConfigDefault/range: 0.0
    * /move_group/planner_configs/BKPIECEkConfigDefault/type: geometric::BKPIECE
    * /move_group/planner_configs/BiESTkConfigDefault/range: 0.0
    * /move_group/planner_configs/BiESTkConfigDefault/type: geometric::BiEST
    * /move_group/planner_configs/BiTRRTkConfigDefault/cost_threshold: 1e300
    * /move_group/planner_configs/BiTRRTkConfigDefault/frountier_node_ratio: 0.1
    * /move_group/planner_configs/BiTRRTkConfigDefault/frountier_threshold: 0.0
    * /move_group/planner_configs/BiTRRTkConfigDefault/init_temperature: 100
    * /move_group/planner_configs/BiTRRTkConfigDefault/range: 0.0
    * /move_group/planner_configs/BiTRRTkConfigDefault/temp_change_factor: 0.1
    * /move_group/planner_configs/BiTRRTkConfigDefault/type: geometric::BiTRRT
    * /move_group/planner_configs/ESTkConfigDefault/goal_bias: 0.05
    * /move_group/planner_configs/ESTkConfigDefault/range: 0.0
    * /move_group/planner_configs/ESTkConfigDefault/type: geometric::EST
    * /move_group/planner_configs/FMTkConfigDefault/cache_cc: 1
    * /move_group/planner_configs/FMTkConfigDefault/extended_fmt: 1
    * /move_group/planner_configs/FMTkConfigDefault/heuristics: 0
    * /move_group/planner_configs/FMTkConfigDefault/nearest_k: 1
    * /move_group/planner_configs/FMTkConfigDefault/num_samples: 1000
    * /move_group/planner_configs/FMTkConfigDefault/radius_multiplier: 1.1
    * /move_group/planner_configs/FMTkConfigDefault/type: geometric::FMT
    * /move_group/planner_configs/KPIECEkConfigDefault/border_fraction: 0.9
    * /move_group/planner_configs/KPIECEkConfigDefault/failed_expansion_score_factor: 0.5
    * /move_group/planner_configs/KPIECEkConfigDefault/goal_bias: 0.05
    * /move_group/planner_configs/KPIECEkConfigDefault/min_valid_path_fraction: 0.5
    * /move_group/planner_configs/KPIECEkConfigDefault/range: 0.0
    * /move_group/planner_configs/KPIECEkConfigDefault/type: geometric::KPIECE
    * /move_group/planner_configs/LBKPIECEkConfigDefault/border_fraction: 0.9
    * /move_group/planner_configs/LBKPIECEkConfigDefault/min_valid_path_fraction: 0.5
    * /move_group/planner_configs/LBKPIECEkConfigDefault/range: 0.0
    * /move_group/planner_configs/LBKPIECEkConfigDefault/type: geometric::LBKPIECE
    * /move_group/planner_configs/LBTRRTkConfigDefault/epsilon: 0.4
    * /move_group/planner_configs/LBTRRTkConfigDefault/goal_bias: 0.05
    * /move_group/planner_configs/LBTRRTkConfigDefault/range: 0.0
    * /move_group/planner_configs/LBTRRTkConfigDefault/type: geometric::LBTRRT
    * /move_group/planner_configs/LazyPRMkConfigDefault/range: 0.0
    * /move_group/planner_configs/LazyPRMkConfigDefault/type: geometric::LazyPRM
    * /move_group/planner_configs/LazyPRMstarkConfigDefault/type: geometric::LazyPR…
    * /move_group/planner_configs/PDSTkConfigDefault/type: geometric::PDST
    * /move_group/planner_configs/PRMkConfigDefault/max_nearest_neighbors: 10
    * /move_group/planner_configs/PRMkConfigDefault/type: geometric::PRM
    * /move_group/planner_configs/PRMstarkConfigDefault/type: geometric::PRMstar
    * /move_group/planner_configs/ProjESTkConfigDefault/goal_bias: 0.05
    * /move_group/planner_configs/ProjESTkConfigDefault/range: 0.0
    * /move_group/planner_configs/ProjESTkConfigDefault/type: geometric::ProjEST
    * /move_group/planner_configs/RRTConnectkConfigDefault/range: 0.0
    * /move_group/planner_configs/RRTConnectkConfigDefault/type: geometric::RRTCon…
    * /move_group/planner_configs/RRTkConfigDefault/goal_bias: 0.05
    * /move_group/planner_configs/RRTkConfigDefault/range: 0.0
    * /move_group/planner_configs/RRTkConfigDefault/type: geometric::RRT
    * /move_group/planner_configs/RRTstarkConfigDefault/delay_collision_checking: 1
    * /move_group/planner_configs/RRTstarkConfigDefault/goal_bias: 0.05
    * /move_group/planner_configs/RRTstarkConfigDefault/range: 0.0
    * /move_group/planner_configs/RRTstarkConfigDefault/type: geometric::RRTstar
    * /move_group/planner_configs/SBLkConfigDefault/range: 0.0
    * /move_group/planner_configs/SBLkConfigDefault/type: geometric::SBL
    * /move_group/planner_configs/SPARSkConfigDefault/dense_delta_fraction: 0.001
    * /move_group/planner_configs/SPARSkConfigDefault/max_failures: 1000
    * /move_group/planner_configs/SPARSkConfigDefault/sparse_delta_fraction: 0.25
    * /move_group/planner_configs/SPARSkConfigDefault/stretch_factor: 3.0
    * /move_group/planner_configs/SPARSkConfigDefault/type: geometric::SPARS
    * /move_group/planner_configs/SPARStwokConfigDefault/dense_delta_fraction: 0.001
    * /move_group/planner_configs/SPARStwokConfigDefault/max_failures: 5000
    * /move_group/planner_configs/SPARStwokConfigDefault/sparse_delta_fraction: 0.25
    * /move_group/planner_configs/SPARStwokConfigDefault/stretch_factor: 3.0
    * /move_group/planner_configs/SPARStwokConfigDefault/type: geometric::SPARStwo
    * /move_group/planner_configs/STRIDEkConfigDefault/degree: 16
    * /move_group/planner_configs/STRIDEkConfigDefault/estimated_dimension: 0.0
    * /move_group/planner_configs/STRIDEkConfigDefault/goal_bias: 0.05
    * /move_group/planner_configs/STRIDEkConfigDefault/max_degree: 18
    * /move_group/planner_configs/STRIDEkConfigDefault/max_pts_per_leaf: 6
    * /move_group/planner_configs/STRIDEkConfigDefault/min_degree: 12
    * /move_group/planner_configs/STRIDEkConfigDefault/min_valid_path_fraction: 0.2
    * /move_group/planner_configs/STRIDEkConfigDefault/range: 0.0
    * /move_group/planner_configs/STRIDEkConfigDefault/type: geometric::STRIDE
    * /move_group/planner_configs/STRIDEkConfigDefault/use_projected_distance: 0
    * /move_group/planner_configs/TRRTkConfigDefault/frountierNodeRatio: 0.1
    * /move_group/planner_configs/TRRTkConfigDefault/frountier_threshold: 0.0
    * /move_group/planner_configs/TRRTkConfigDefault/goal_bias: 0.05
    * /move_group/planner_configs/TRRTkConfigDefault/init_temperature: 10e-6
    * /move_group/planner_configs/TRRTkConfigDefault/k_constant: 0.0
    * /move_group/planner_configs/TRRTkConfigDefault/max_states_failed: 10
    * /move_group/planner_configs/TRRTkConfigDefault/min_temperature: 10e-10
    * /move_group/planner_configs/TRRTkConfigDefault/range: 0.0
    * /move_group/planner_configs/TRRTkConfigDefault/temp_change_factor: 2.0
    * /move_group/planner_configs/TRRTkConfigDefault/type: geometric::TRRT
    * /move_group/planning_plugin: ompl_interface/OM…
    * /move_group/planning_scene_monitor/publish_geometry_updates: True
    * /move_group/planning_scene_monitor/publish_planning_scene: True
    * /move_group/planning_scene_monitor/publish_state_updates: True
    * /move_group/planning_scene_monitor/publish_transforms_updates: True
    * /move_group/request_adapters: default_planner_r…
    * /move_group/start_state_max_bounds_error: 0.1
    * /move_group/trajectory_execution/allowed_execution_duration_scaling: 1.2
    * /move_group/trajectory_execution/allowed_goal_duration_margin: 0.5
    * /move_group/trajectory_execution/allowed_start_tolerance: 0.01
    * /move_group/trajectory_execution/execution_duration_monitoring: False
    * /move_group/use_controller_manager: False
    * /robot_description: <?xml version=”1….
    * /robot_description_kinematics/edo/kinematics_solver: kdl_kinematics_pl…
    * /robot_description_kinematics/edo/kinematics_solver_attempts: 3
    * /robot_description_kinematics/edo/kinematics_solver_search_resolution: 0.005
    * /robot_description_kinematics/edo/kinematics_solver_timeout: 0.005
    * /robot_description_planning/joint_limits/edo_joint_1/has_acceleration_limits: True
    * /robot_description_planning/joint_limits/edo_joint_1/has_velocity_limits: True
    * /robot_description_planning/joint_limits/edo_joint_1/max_acceleration: 0.5
    * /robot_description_planning/joint_limits/edo_joint_1/max_velocity: 0.35
    * /robot_description_planning/joint_limits/edo_joint_2/has_acceleration_limits: True
    * /robot_description_planning/joint_limits/edo_joint_2/has_velocity_limits: True
    * /robot_description_planning/joint_limits/edo_joint_2/max_acceleration: 0.5
    * /robot_description_planning/joint_limits/edo_joint_2/max_velocity: 0.35
    * /robot_description_planning/joint_limits/edo_joint_3/has_acceleration_limits: True
    * /robot_description_planning/joint_limits/edo_joint_3/has_velocity_limits: True
    * /robot_description_planning/joint_limits/edo_joint_3/max_acceleration: 0.5
    * /robot_description_planning/joint_limits/edo_joint_3/max_velocity: 0.35
    * /robot_description_planning/joint_limits/edo_joint_4/has_acceleration_limits: True
    * /robot_description_planning/joint_limits/edo_joint_4/has_velocity_limits: True
    * /robot_description_planning/joint_limits/edo_joint_4/max_acceleration: 0.5
    * /robot_description_planning/joint_limits/edo_joint_4/max_velocity: 0.35
    * /robot_description_planning/joint_limits/edo_joint_5/has_acceleration_limits: True
    * /robot_description_planning/joint_limits/edo_joint_5/has_velocity_limits: True
    * /robot_description_planning/joint_limits/edo_joint_5/max_acceleration: 0.5
    * /robot_description_planning/joint_limits/edo_joint_5/max_velocity: 0.35
    * /robot_description_planning/joint_limits/edo_joint_6/has_acceleration_limits: True
    * /robot_description_planning/joint_limits/edo_joint_6/has_velocity_limits: True
    * /robot_description_planning/joint_limits/edo_joint_6/max_acceleration: 0.5
    * /robot_description_planning/joint_limits/edo_joint_6/max_velocity: 0.35
    * /robot_description_semantic: <?xml version=”1….
    * /rosdistro: melodic
    * /rosversion: 1.14.3
    * /rviz_CAT_VM_3121_8237613409242926205/edo/kinematics_solver: kdl_kinematics_pl…
    * /rviz_CAT_VM_3121_8237613409242926205/edo/kinematics_solver_attempts: 3
    * /rviz_CAT_VM_3121_8237613409242926205/edo/kinematics_solver_search_resolution: 0.005
    * /rviz_CAT_VM_3121_8237613409242926205/edo/kinematics_solver_timeout: 0.005

    NODES
    /
    joint_state_publisher (edo_control/joint_state_publisher.py)
    joint_trajectory_action_server (edo_control/joint_trajectory_action_server.py)
    move_group (moveit_ros_move_group/move_group)
    robot_state_publisher (robot_state_publisher/robot_state_publisher)
    rviz_CAT_VM_3121_8237613409242926205 (rviz/rviz)

    ROS_MASTER_URI=http://10.42.0.49:11311

    process[joint_state_publisher-1]: started with pid [3133]
    process[joint_trajectory_action_server-2]: started with pid [3134]
    process[robot_state_publisher-3]: started with pid [3135]
    process[move_group-4]: started with pid [3136]
    process[rviz_CAT_VM_3121_8237613409242926205-5]: started with pid [3137]
    [ INFO] [1557305996.588464403]: Loading robot model ‘edo’…
    [ INFO] [1557305996.600984339]: No root/virtual joint specified in SRDF. Assuming fixed joint
    [ INFO] [1557305996.660804314]: rviz version 1.13.3
    [ INFO] [1557305996.660914184]: compiled against Qt version 5.9.5
    [ INFO] [1557305996.660963994]: compiled against OGRE version 1.9.0 (Ghadamon)
    [ WARN] [1557305997.143581855]: Kinematics solver doesn’t support #attempts anymore, but only a timeout.
    Please remove the parameter ‘/robot_description_kinematics/edo/kinematics_solver_attempts’ from your configuration.
    [ INFO] [1557305998.065876503]: Stereo is NOT SUPPORTED
    [ INFO] [1557305998.729189743]: OpenGl version: 2.1 (GLSL 1.2).
    [INFO] [1557305998.859645]: Initializing joint trajectory action server…
    [INFO] [1557305998.893869]: Starting eDo joint state publisher for real robot…
    [ INFO] [1557305999.164883073]: Publishing maintained planning scene on ‘monitored_planning_scene’
    [ INFO] [1557306000.609750219]: MoveGroup debug mode is ON
    Starting planning scene monitors…
    [ INFO] [1557306000.610254096]: Starting planning scene monitor
    [ INFO] [1557306000.703870088]: Listening to ‘/planning_scene’
    [ INFO] [1557306000.704386259]: Starting world geometry update monitor for collision objects, attached objects, octomap updates.
    [ INFO] [1557306000.820433147]: Listening to ‘/collision_object’ using message notifier with target frame ‘world ‘
    [ INFO] [1557306000.911067752]: Listening to ‘/planning_scene_world’ for planning scene world geometry
    [INFO] [1557306002.500408]: Current machine state: CALIBRATED (2), opcode 0
    [ INFO] [1557306002.550896475]: Listening to ‘/attached_collision_object’ for attached collision objects
    Planning scene monitors started.
    [ INFO] [1557306002.641418123]: Initializing OMPL interface using ROS parameters
    [INFO] [1557306002.679419]: Waiting for the service that disables the robot’s internal algorithm manager…
    [WARN] [1557306002.720974]: Cannot disable internal robot’s algorithm manager, perhaps it is already disabled
    [INFO] [1557306003.260309]: code line reached,next is server start
    [INFO] [1557306004.996918]: Running JTAS. Ctrl-c to quit
    [ INFO] [1557306005.046233016]: Using planning interface ‘OMPL’
    [ INFO] [1557306005.062557512]: Param ‘default_workspace_bounds’ was not set. Using default value: 10
    [ INFO] [1557306005.070323186]: Param ‘start_state_max_bounds_error’ was set to 0.1
    [ INFO] [1557306005.077399020]: Param ‘start_state_max_dt’ was not set. Using default value: 0.5
    [ INFO] [1557306005.087795576]: Param ‘start_state_max_dt’ was not set. Using default value: 0.5
    [ INFO] [1557306005.095376127]: Param ‘jiggle_fraction’ was set to 0.05
    [ INFO] [1557306005.102438567]: Param ‘max_sampling_attempts’ was not set. Using default value: 100
    [ INFO] [1557306005.102801620]: Using planning request adapter ‘Add Time Parameterization’
    [ INFO] [1557306005.102973459]: Using planning request adapter ‘Fix Workspace Bounds’
    [ INFO] [1557306005.103073927]: Using planning request adapter ‘Fix Start State Bounds’
    [ INFO] [1557306005.103161424]: Using planning request adapter ‘Fix Start State In Collision’
    [ INFO] [1557306005.103264166]: Using planning request adapter ‘Fix Start State Path Constraints’
    [ INFO] [1557306007.150135542]: Loading robot model ‘edo’…
    [ INFO] [1557306007.150236527]: No root/virtual joint specified in SRDF. Assuming fixed joint
    [ WARN] [1557306007.730260560]: Kinematics solver doesn’t support #attempts anymore, but only a timeout.
    Please remove the parameter ‘/rviz_CAT_VM_3121_8237613409242926205/edo/kinematics_solver_attempts’ from your configuration.
    [ INFO] [1557306008.698206908]: Starting planning scene monitor
    [ INFO] [1557306008.780697571]: Listening to ‘/move_group/monitored_planning_scene’
    [ INFO] [1557306008.796177127]: waitForService: Service [/get_planning_scene] has not been advertised, waiting…
    [ WARN] [1557306010.462403421]: Waiting for /follow_joint_trajectory to come up
    [ INFO] [1557306013.829241942]: Failed to call service get_planning_scene, have you launched move_group? at /tmp/binarydeb/ros-melodic-moveit-ros-planning-1.0.1/planning_scene_monitor/src/planning_scene_monitor.cpp:495
    [ INFO] [1557306015.277122940]: Constructing new MoveGroup connection for group ‘edo’ in namespace ”
    [ WARN] [1557306016.462888288]: Waiting for /follow_joint_trajectory to come up
    QObject::connect: Cannot queue arguments of type ‘QVector<int>’
    (Make sure ‘QVector<int>’ is registered using qRegisterMetaType().)
    QObject::connect: Cannot queue arguments of type ‘QVector<int>’
    (Make sure ‘QVector<int>’ is registered using qRegisterMetaType().)
    [ERROR] [1557306022.464440146]: Action client not connected: /follow_joint_trajectory
    [ INFO] [1557306022.632309054]: Returned 0 controllers in list
    [ INFO] [1557306024.363225803]: Trajectory execution is managing controllers
    Loading ‘move_group/ApplyPlanningSceneService’…
    Loading ‘move_group/ClearOctomapService’…
    Loading ‘move_group/MoveGroupCartesianPathService’…
    Loading ‘move_group/MoveGroupExecuteTrajectoryAction’…
    Loading ‘move_group/MoveGroupGetPlanningSceneService’…
    Loading ‘move_group/MoveGroupKinematicsService’…
    Loading ‘move_group/MoveGroupMoveAction’…
    Loading ‘move_group/MoveGroupPickPlaceAction’…
    Loading ‘move_group/MoveGroupPlanService’…
    Loading ‘move_group/MoveGroupQueryPlannersService’…
    Loading ‘move_group/MoveGroupStateValidationService’…
    [ INFO] [1557306027.354433316]:

    ********************************************************
    * MoveGroup using:
    * – ApplyPlanningSceneService
    * – ClearOctomapService
    * – CartesianPathService
    * – ExecuteTrajectoryAction
    * – GetPlanningSceneService
    * – KinematicsService
    * – MoveAction
    * – PickPlaceAction
    * – MotionPlanService
    * – QueryPlannersService
    * – StateValidationService
    ********************************************************

    [ INFO] [1557306027.355291470]: MoveGroup context using planning plugin ompl_interface/OMPLPlanner
    [ INFO] [1557306027.355433819]: MoveGroup context initialization complete

    You can start planning now!

    [ERROR] [1557306046.860048760]: Unable to connect to move_group action server ‘move_group’ within allotted time (30s)
    [ INFO] [1557306046.870134342]: Constructing new MoveGroup connection for group ‘edo’ in namespace ”
    [ERROR] [1557306077.110671557]: Unable to connect to move_group action server ‘move_group’ within allotted time (30s)

    #8179
    Pietro Castelli
    Participant

    Hi Yoan, i made some step further, i installed qt5 on my machine cause i noticed i was having error about qtvector when launching edo moveit, now everything is smooth untill i try to execute a planned trajectory, somehow i am missing controllers for joints and the error about qtvector is still present but it show up in a different moment

    [ INFO] [1557308195.213830965]: Loading robot model ‘edo’…
    [ INFO] [1557308195.214689874]: No root/virtual joint specified in SRDF. Assuming fixed joint
    [ WARN] [1557308195.539884534]: Kinematics solver doesn’t support #attempts anymore, but only a timeout.
    Please remove the parameter ‘/robot_description_kinematics/edo/kinematics_solver_attempts’ from your configuration.
    [ INFO] [1557308195.546084488]: rviz version 1.13.3
    [ INFO] [1557308195.546181927]: compiled against Qt version 5.9.5
    [ INFO] [1557308195.546232635]: compiled against OGRE version 1.9.0 (Ghadamon)
    [ INFO] [1557308195.936639039]: Publishing maintained planning scene on ‘monitored_planning_scene’
    [ INFO] [1557308195.942530837]: MoveGroup debug mode is ON
    Starting planning scene monitors…
    [ INFO] [1557308195.942611354]: Starting planning scene monitor
    [ INFO] [1557308195.947002059]: Listening to ‘/planning_scene’
    [ INFO] [1557308195.947083271]: Starting world geometry update monitor for collision objects, attached objects, octomap updates.
    [ INFO] [1557308195.954112292]: Listening to ‘/collision_object’ using message notifier with target frame ‘world ‘
    [ INFO] [1557308195.958695773]: Listening to ‘/planning_scene_world’ for planning scene world geometry
    [ INFO] [1557308196.025996629]: Listening to ‘/attached_collision_object’ for attached collision objects
    Planning scene monitors started.
    [ INFO] [1557308196.079522700]: Initializing OMPL interface using ROS parameters
    [ INFO] [1557308196.148895001]: Using planning interface ‘OMPL’
    [ INFO] [1557308196.151742396]: Param ‘default_workspace_bounds’ was not set. Using default value: 10
    [ INFO] [1557308196.154227478]: Param ‘start_state_max_bounds_error’ was set to 0.1
    [ INFO] [1557308196.154649875]: Param ‘start_state_max_dt’ was not set. Using default value: 0.5
    [ INFO] [1557308196.155137222]: Param ‘start_state_max_dt’ was not set. Using default value: 0.5
    [ INFO] [1557308196.155536803]: Param ‘jiggle_fraction’ was set to 0.05
    [ INFO] [1557308196.157148317]: Param ‘max_sampling_attempts’ was not set. Using default value: 100
    [ INFO] [1557308196.157320250]: Using planning request adapter ‘Add Time Parameterization’
    [ INFO] [1557308196.157468919]: Using planning request adapter ‘Fix Workspace Bounds’
    [ INFO] [1557308196.157601510]: Using planning request adapter ‘Fix Start State Bounds’
    [ INFO] [1557308196.157731348]: Using planning request adapter ‘Fix Start State In Collision’
    [ INFO] [1557308196.157914470]: Using planning request adapter ‘Fix Start State Path Constraints’
    [INFO] [1557308196.370419]: Starting eDo joint state publisher for real robot…
    [INFO] [1557308197.099628]: Initializing joint trajectory action server…
    [ INFO] [1557308197.149885827]: Stereo is NOT SUPPORTED
    [ INFO] [1557308197.154665036]: OpenGl version: 2.1 (GLSL 1.2).
    [INFO] [1557308197.242404]: Waiting for the service that disables the robot’s internal algorithm manager…
    [ INFO] [1557308200.578028382]: Loading robot model ‘edo’…
    [ INFO] [1557308200.582715083]: No root/virtual joint specified in SRDF. Assuming fixed joint
    [ WARN] [1557308200.726285468]: Kinematics solver doesn’t support #attempts anymore, but only a timeout.
    Please remove the parameter ‘/rviz_CAT_VM_4470_2901311845468455608/edo/kinematics_solver_attempts’ from your configuration.
    [ INFO] [1557308201.049878533]: Starting planning scene monitor
    [ INFO] [1557308201.054559050]: Listening to ‘/move_group/monitored_planning_scene’
    [ INFO] [1557308201.055904196]: waitForService: Service [/get_planning_scene] has not been advertised, waiting…
    [ WARN] [1557308201.188147043]: Waiting for /follow_joint_trajectory to come up
    [ INFO] [1557308206.071092885]: Failed to call service get_planning_scene, have you launched move_group? at /tmp/binarydeb/ros-melodic-moveit-ros-planning-1.0.1/planning_scene_monitor/src/planning_scene_monitor.cpp:495
    [ WARN] [1557308207.188565678]: Waiting for /follow_joint_trajectory to come up
    [ INFO] [1557308207.289239854]: Constructing new MoveGroup connection for group ‘edo’ in namespace ”
    [ERROR] [1557308213.188807211]: Action client not connected: /follow_joint_trajectory
    [ INFO] [1557308213.256092731]: Returned 0 controllers in list
    [ INFO] [1557308213.301230023]: Trajectory execution is managing controllers
    Loading ‘move_group/ApplyPlanningSceneService’…
    Loading ‘move_group/ClearOctomapService’…
    Loading ‘move_group/MoveGroupCartesianPathService’…
    Loading ‘move_group/MoveGroupExecuteTrajectoryAction’…
    Loading ‘move_group/MoveGroupGetPlanningSceneService’…
    Loading ‘move_group/MoveGroupKinematicsService’…
    Loading ‘move_group/MoveGroupMoveAction’…
    Loading ‘move_group/MoveGroupPickPlaceAction’…
    Loading ‘move_group/MoveGroupPlanService’…
    Loading ‘move_group/MoveGroupQueryPlannersService’…
    Loading ‘move_group/MoveGroupStateValidationService’…
    [ INFO] [1557308213.443279159]:

    ********************************************************
    * MoveGroup using:
    * – ApplyPlanningSceneService
    * – ClearOctomapService
    * – CartesianPathService
    * – ExecuteTrajectoryAction
    * – GetPlanningSceneService
    * – KinematicsService
    * – MoveAction
    * – PickPlaceAction
    * – MotionPlanService
    * – QueryPlannersService
    * – StateValidationService
    ********************************************************

    [ INFO] [1557308213.443480374]: MoveGroup context using planning plugin ompl_interface/OMPLPlanner
    [ INFO] [1557308213.443629204]: MoveGroup context initialization complete

    You can start planning now!

    [ INFO] [1557308214.465391999]: Ready to take commands for planning group edo.
    [ INFO] [1557308214.465674541]: Looking around: no
    [ INFO] [1557308214.466009847]: Replanning: no
    [ INFO] [1557308240.641889788]: Didn’t received robot state (joint angles) with recent timestamp within 1 seconds.
    Check clock synchronization if your are running ROS across multiple machines!
    [ WARN] [1557308240.641962416]: Failed to fetch current robot state.
    [ INFO] [1557308240.642160296]: Planning request received for MoveGroup action. Forwarding to planning pipeline.
    [ INFO] [1557308240.644072398]: Planner configuration ‘edo[RRTkConfigDefault]’ will use planner ‘geometric::RRT’. Additional configuration parameters will be set when the planner is constructed.
    [ INFO] [1557308240.647355174]: edo[RRTkConfigDefault]: Starting planning with 1 states already in datastructure
    [ INFO] [1557308240.654391572]: edo[RRTkConfigDefault]: Starting planning with 1 states already in datastructure
    [ INFO] [1557308240.668925093]: edo[RRTkConfigDefault]: Starting planning with 1 states already in datastructure
    [ INFO] [1557308240.669801669]: edo[RRTkConfigDefault]: Starting planning with 1 states already in datastructure
    [ INFO] [1557308240.762372258]: edo[RRTkConfigDefault]: Created 23 states
    [ INFO] [1557308240.784452752]: edo[RRTkConfigDefault]: Created 37 states
    [ INFO] [1557308240.800234417]: edo[RRTkConfigDefault]: Created 29 states
    [ INFO] [1557308240.817826623]: edo[RRTkConfigDefault]: Created 54 states
    [ INFO] [1557308240.818404965]: ParallelPlan::solve(): Solution found by one or more threads in 0.171860 seconds
    [ INFO] [1557308240.826833492]: edo[RRTkConfigDefault]: Starting planning with 1 states already in datastructure
    [ INFO] [1557308240.830448804]: edo[RRTkConfigDefault]: Starting planning with 1 states already in datastructure
    [ INFO] [1557308240.832687178]: edo[RRTkConfigDefault]: Starting planning with 1 states already in datastructure
    [ INFO] [1557308240.836472376]: edo[RRTkConfigDefault]: Starting planning with 1 states already in datastructure
    [ INFO] [1557308240.866888455]: edo[RRTkConfigDefault]: Created 8 states
    [ INFO] [1557308240.946125221]: edo[RRTkConfigDefault]: Created 24 states
    [ INFO] [1557308240.989170148]: edo[RRTkConfigDefault]: Created 44 states
    [ INFO] [1557308240.998600230]: edo[RRTkConfigDefault]: Created 49 states
    [ INFO] [1557308240.998957653]: ParallelPlan::solve(): Solution found by one or more threads in 0.173325 seconds
    [ INFO] [1557308240.999315278]: edo[RRTkConfigDefault]: Starting planning with 1 states already in datastructure
    [ INFO] [1557308241.005417731]: edo[RRTkConfigDefault]: Starting planning with 1 states already in datastructure
    [ INFO] [1557308241.037203022]: edo[RRTkConfigDefault]: Created 12 states
    [ INFO] [1557308241.076130254]: edo[RRTkConfigDefault]: Created 45 states
    [ INFO] [1557308241.078676080]: ParallelPlan::solve(): Solution found by one or more threads in 0.079486 seconds
    [ INFO] [1557308241.090931572]: SimpleSetup: Path simplification took 0.012020 seconds and changed from 3 to 2 states
    QObject::connect: Cannot queue arguments of type ‘QVector<int>’
    (Make sure ‘QVector<int>’ is registered using qRegisterMetaType().)
    QObject::connect: Cannot queue arguments of type ‘QVector<int>’
    (Make sure ‘QVector<int>’ is registered using qRegisterMetaType().)

    [ INFO] [1557308243.321043712]: Execution request received
    [ INFO] [1557308243.321125935]: Returned 0 controllers in list
    [ERROR] [1557308243.321187390]: Unable to identify any set of controllers that can actuate the specified joints: [ edo_joint_1 edo_joint_2 edo_joint_3 edo_joint_4 edo_joint_5 edo_joint_6 ]
    [ERROR] [1557308243.321226952]: Known controllers and their joints:

    [ INFO] [1557308243.341134117]: ABORTED: Solution found but controller failed during execution

    #8180
    Yoan Mollard
    Participant

    You’ve made a step backwards, because this stacktrace shows that the robot cannot be contacted:
    As you can see Waiting for the service that disables the robot’s internal algorithm manager… does not end up to a response from the robot, while you had a response in your first post here. Haven’t your forgotten to run start.bash first?

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.